Account Access
Incident Report for Lucky Orange
Resolved
We have resolved the latency issues and access to the app should be fully operational.
Posted May 15, 2023 - 11:09 CDT
Identified
We have identified latency issues with accessing accounts on Lucky Orange. We are working to resolve the issue and will provide updates as we have them.
Posted May 15, 2023 - 08:17 CDT
This incident affected: Web App.