Delay in data processing

Incident Report for Lucky Orange

Resolved

All data has now been processed and is up to date. We appreciate your patience through the delay.
Posted Jan 07, 2026 - 17:15 CST

Identified

We’ve identified an issue affecting the speed at which incoming data appears in some accounts. We are actively working on a resolution.

Please be aware that once the service is restored, it may take some time for all data to "catch up" and appear in your dashboard. Thanks for bearing with us.
Posted Jan 07, 2026 - 15:58 CST
This incident affected: Data Collection.