Access to Lucky Orange App
Incident Report for Lucky Orange
Resolved
All access has been restored. We appreciate your patience and please reach out to support at support@luckyorange.com if you continue to have trouble accessing your account.
Posted Jan 09, 2023 - 11:23 CST
Update
The updates are taking a bit longer than expected, we will make sure to update everyone as soon as access is restored. Thanks for your patience.
Posted Jan 09, 2023 - 10:51 CST
Investigating
We are currently restarting a few of our services and access to the app may be down momentarily. We will let you know as soon as access has been fully restored.
Posted Jan 09, 2023 - 10:35 CST
This incident affected: Web App.