App Status

Incident Report for Lucky Orange

Resolved

This incident has been resolved.
Posted Jun 26, 2023 - 16:15 CDT

Update

We are continuing to work on a fix for this issue.
Posted Jun 26, 2023 - 14:22 CDT

Identified

We are experiencing delays with data loading throughout the app. We have identified the cause, and should have all systems back up and running shortly. We'll update this page with additional information as it becomes available. Thank you for your understanding and patience.
Posted Jun 26, 2023 - 14:08 CDT
This incident affected: Data Collection.